Mysql, Apache, PHP Kurtulma !

Merhaba arkadaşlar,
Bugün günlerden pazar evde oturmuş yeni kurulumu bitmiş elementary OSa gerekli uygulamaları kuruyorum. mysql server kurdum ama 1045 hatası almaya başladım ve cıldırmak üzereydim. ne ettiysem sorunu düzeltemedim. sileyim dedim silemedim 😀
Google amcamıza sordum bir cözüm bulamadım en azından ben. sonra asil balaban abimizin sitesinde bunla alakalı ufacık bir komut oldugunu gördüm hemen test ettim ve sonunda kurtuldum! Komutların bir kopyasını burda yayınladım. sitesine burdan ulaşabilirsiniz


sudo apt-get purge mysql-server apache2 php5

sudo apt-get remove apache2 apache2-mpm-prefork apache2-utils apache2.2-common libapache2-mod-php5 libapr1 libaprutil1 libdbd-mysql-perl libdbi-perl libmysqlclient15off libnet-daemon-perl libplrpc-perl libpq5 mysql-client-5.0 mysql-common mysql-server mysql-server-5.0 php5-common php5-mysql

ikinci grup işe yaramazsa ki bende yaramadı bunu kullanın

sudo apt-get purge apache2 php5-cli apache2-mpm-prefork apache2-utils apache2.2-common libapache2-mod-php5 libapr1 libaprutil1 libdbd-mysql-perl libdbi-perl libnet-daemon-perl libplrpc-perl libpq5 mysql-client mysql-common mysql-server php5-common php5-mysql phpmyadmin && sudo apt-get autoremove

ve son olarakta

sudo rm -r /etc/apache2/

ubuntu komutları ekle,kaldir,sil,yükle

Windows ailesinden kurtulma yolunda emin adımlarla ilerlememize devam ediyoruz. windowssuz yapabilir miyim diye düşündüğüm günlere şimdi sadece tebessüm ederek hatırlıyorum. Linux ailesi ubuntu,elemantary,fedora,linuxmint,debian,centos vb dağıtımlar hepsinin içinde size hitap eden bir sürüm kesinlikle vardır. Deneyin pişman olmazsınız.

Temelde lazım olan terminal komutlarımız;

depo durumunu güncellemek için ;

apt-get update

sistemi güncellemek için ;

apt-get upgrade

değişen bağımlılıkları da katarak sistemi güncellemek için ;

apt-get dist-upgrade

paket (uygulama) yüklemek istediğimizde ;

apt-get install paketismi
Örneğin : apt-get install mc veya apt-get install youtube-dl

paketi (uygulama) yeniden yüklemek için ;

apt-get --reinstall paketismi

paketi (uygulama) kaldırmak için ;

apt-get remove paketismi

paketi yapılandırma dosyaları ile birlikte kaldırmak istiyorsak ;

apt-get purge paketismi

localhost kurulumu + phpmyadmin

localhost kurulumu için ubuntu, elemantary ve diğer linux dağıtımları için sırasıyla uygulayın, Ubuntu üzerine işa edilen elemantary os kullanıyorum sorunsuz bir şekilde kurulum yaptım ve sorunsuz bir şekilde kullanıyorum.

sudo apt-get update
sudo apt-get install apache2
sudo apt-get install php5 php5-mysql mysql-server
sudo apt-get install phpmyadmin

phpmyadmin çalışma bunu uygulayın ;

ln -sf /usr/share/phpmyadmin /var/www/phpmyadmin

www klasörüne dosya yazamıyorsanız bunu uygulayın ;

sudo chown kullanıcıadınız -R /var/www

Kurulu olanları ve olmayanları görmek için ;

sudo nano /var/www/phpinfo.php

Resetlemek, Durdurmak, Başlatmak İçin ;

sudo /etc/init.d/apache2 restart
sudo /etc/init.d/apache2 stop
sudo /etc/init.d/apache2 start

zamanla gelen güncelleme veya sürüm farkından kaynaklanan hatalar olabilir, bildirirseniz bende konuya dahil etmekten mutlu olurum.

İyi Çalışmalar

 

Güncelleme : Ubuntu 16.04 İçin ->

sudo add-apt-repository ppa:ondrej/php
sudo apt-get update
sudo apt-get install php5.6
sudo apt-get install php5.6-mbstring php5.6-mcrypt php5.6-mysql php5.6-xml

 

bundle Dosyasını Yükleme

Linux ailesinden Elemantary dağıtımının Freya versiyonunu kullanıyorum. vmware kurulumu yapmam gerekti indirdiğim dosya bundle uzantılı çıktı. Ubuntu Forumunda bulduğum şekli ile çalıştırdım. Sizinde bildiğiniz bir yöntem varsa benimle paylaşın onuda öğrenmiş olalım.

Kod :

sudo sh VMware-Player-2.5.1-126130.i386.bundle

kodu çalıştırdığınızda yükleme ekranı ekranınızda belirmesi lazım. sorun yaşarsanız çözümünde yardımcı olmaktan mutluluk duyarım. lütfen yorum kısmına sorununuzu yazınız.

Elementary Freya Merhaba

Ubuntu üzerine geliştirilen Elemantary Freya sürümünü kullanmaya başladım. Görsellik diğer linux dağıtımlarının yanında kesinlikle en güzeli. Elemantary ubuntu üzerinden gittiği için ubuntu için olan herseyi kullanabiliyorsunuz. Sorunlarınız varsa ubuntu gibi arama yapıp çözebilirsiniz. İlerleyen günlerde karşılaştığım veya gördüklerimi sizlerle paylaşaçağım.

İSO dosyasını indirmek istediğinizde yardım etmenizi için bir input alanı var 0 yazıp indirebilirsiniz. Yardımda edebilirsiniz tabi size kalmış 🙂

Daha Fazla Bilgi İçin Tıklayın